INTRO TO ADVANCED INDESIGN
see naomigraphics.com/indesign for more links
and all these links active
Adobe InDesign I will cover the basic logic of the
InDesign program, now we will work more indepth averall
workings of the program. See how the Library and book
features work. More indepth with style sheet, hidden and
hard to find treasures. Using the find and replace with more
depth. Also with work with tables and forms. Also working
with the panels.
By design Indesign is similar to that of all Creative Suite
5 programs. You have a Menu Bar on top, the Tools and
the Panels. Panels are little windows which have specialized
functions, e.g., you have one that handles colors, one that
handles paragraphs, one that handles pages, etc. By default,
there is a special Panel just under the Menu Bar called
Control Panel. The Control Panel changes depending on
what tool you are using or what you are doing while you are
working with the different items of your layout.

InDesign 5 for Macintosh and
Windows: Visual Quickstart
Sandee Cohen

Paperback - 564 pages
Peachpit Press; ISBN: 987-321-70520-4
InDesign CS6: Visual QuickStart Guide highlights the
important new features, as well as covering the ones readers have
relied on in previous versions of InDesign. Complete coverage
of InDesign CS6’s new features includes: tools for easily outputting to various devices such as phones and notebooks, including
Alternate Layouts, Liquid Layouts, and new content management
tools; linked content tools, too more easily allow repurposing of
content; PDF forms creation feature, including extensive library
resources; enhanced selection and dr awing tools. Users will learn
how to create and automate documents, import and style text and
objects, manage long documents, export files for a wide variety of
purposes, and much more.
http://www.peachpit.com/articles/article.aspx?p=1761171

sites that will cover diofferent ascpects of Indesign (I don’t need to re-event the wheel)
Ten (Very) Quick Tips for InDesign Users!
http://www.creativepro.com/article/10-essential-tips-indesign

InDesign CS Selection, Type, and Line Drawing Tools
http://desktoppub.about.com/od/indesigntutorials/ss/id_selectdraw_3.htm

Adobe InDesign Tips I Wish I’d Known When Starting Out
http://www.smashingmagazine.com/2011/03/17/indesign-tips-i-wish-i-d-known-when-starting-out/

Hidden characters in InDesign - Diane Burns Inc
http://www.dianeburns.com/InDesign_Seminar_Handouts/InDesign_hidden_chars.pdf

Indesign Tips and Tricks
http://www.fluxconsulting.com/adobe-indesign-tips-tricks/
https://layersmagazine.com/14-little-known-indesign-tips.html
https://design.tutsplus.com/tutorials/quick-tip-eleven-tricks-that-will-help-your-workflow-in-indesign--vector-4591

40 brilliant InDesign tutorials
http://www.creativebloq.com/graphic-design-tips/indesign-tutorials-1232639
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window. In Mac OS, this is the green button in the upper left corner of the window.

Viewing and arranging panels
Panels provide quick access to commonly used tools and features. InDesign CS3
provides an entirely new way of working with panels, as you will see.
By default, panels appear in stacked groups, which you can reorganize in various ways.
Here you’ll experiment with hiding, closing, and opening panels.
1 Choose Window > Workspace > Default Workspace to reset the panels to their
original location.
ADOBE INDESIGN
2 Click the double arrow at the top of the dock to expand the dock and display
the CS3 57
Classroom in a Book
panels. Click the Layers tab or choose Window > Layers.

ID_CS3.indd 56

3/27/07 3:47:56 PM

To find a hidden panel, choose the panel name on the Window menu. If the panel
name already has a check mark, then the panel is already open and in front of any other
panels in its panel group. If you choose a checked panel name on the Window menu, the
panel will close.

Dock and undock panels
A dock is a collection of panels or panel groups displayed together, generally in a vertical orientation.
You dock and undock panels by moving them into and out of a dock.
Note: Docking is not the same as stacking. A stack is a collection of free-floating panels or panel
groups, joined top to bottom.

•
•
•

To dock a panel, drag it by its tab into the dock, at the top, bottom, or in between other panels.
To dock a panel group, drag it by its title bar (the solid empty bar above the tabs) into the dock.

To remove a panel or panel group, drag it out of the dock by its tab or title bar. You can drag it into
another dock or make it free-floating.
—From InDesign Help

see panels/workspace
Next
we’ll discuss how to handout
collapse the panels to icons. This can save space when working
on documents.
http://help.adobe.com/en_US/aftereffects/cs/using/WS5421A290-E54C-489f-806F-BCB0C0879136a.
html#WSB21CF943-DC86-4f72-8366-F5FBA47629FC
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PARAGRAPH AND CHARACTER STYLES
A character style is a collection of character formatting
attributes that can be applied to text in a single step.
A paragraph style includes both character and paragraph formatting attributes, and can be applied to a
paragraph or range of paragraphs. Paragraph styles and
character styles are found on separate panels. Paragraph and characters styles are sometimes called text
styles.

Next Style
You can automatically apply styles as you type text. If,
for example, your document’s design calls for the style
“body text” to follow a heading style named “heading
1,” you can set the Next Style option for “heading 1”
to “body text.” After you’ve typed a paragraph styled
with “heading 1,” pressing Enter or Return starts a new
paragraph styled with “body text.”

When you change the formatting of a style, all text to
which the style has been applied will be updated with
the new format.

If you use the context menu when applying a style to
two or more paragraphs, you can cause the parent style
to be applied to the first paragraph and the Next Style
to be applied to the additional paragraphs. (See Apply
styles.)

For a video tutorial on making a paragraph style, see
www.adobe.com/go/lrvid4277_id. For a video tutorial
on using text styles, see www.adobe.com/go/vid0076.
Thomas Silkjaer provides samples of styles at Free InDesign Style Template.
[Basic Paragraph] styles
By default, each new document contains a [Basic Paragraph] style that is applied to text you type. You can
edit this style, but you can’t rename or delete it. You
can rename and delete styles that you create. You can
also select a different default style to apply to text.
Character style attributes
Unlike paragraph styles, character styles do not include
all the formatting attributes of selected text. Instead,
when you create a character style, InDesign makes
only those attributes that are different from the formatting of the selected text part of the style. That way, you
can create a character style that, when applied to text,
changes only some attributes, such as the font family
and size, ignoring all other character attributes. If you
want other attributes to be part of the style, add them
when editing the style.

To use the Next Style feature, choose a style from the
Next Style menu when you’re creating or editing a
style.
Jeff Witchel provides a video tutorial about using the
Next Style feature at Using the Next Style feature.
Styles panel overview
Use the Character Styles panel to create, name, and
apply character styles to text within a paragraph; use
the Paragraph Styles panel to create, name, and apply
paragraph styles to entire paragraphs. Styles are saved
with a document and display in the panel each time
you open that document.
When you select text or position the insertion point,
any style that has been applied to that text is highlighted in either of the Styles panels, unless the style is
in a collapsed style group. If you select a range of text
that contains multiple styles, no style is highlighted in
the Styles panel. If you select a range of text to which
multiple styles are applied, the Styles panel displays
“(Mixed).”

Adobe InDesign-Set Up
Adobe InDesign-Creating a Shape
Adobe InDesign-Importing a Picture
Adobe Indesign-Wrapping Text
Adobe InDesign-Creating Text on a Path
Adobe InDesign-Exporting and Packaging
Adobe InDesign-Page Numbering
Adobe InDesign-Linking Text Boxes
seer: http://sandbox.wcu.edu/?page_id=7517
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NESTED STYLES

See Drop cap and nested styles
Create one or more nested styles
Create one or more character styles that you
want to use to format text.
Do one of the following:
1. To add nested styles to a paragraph style,
double-click the paragraph style, and then
click Drop Caps And Nested Styles.
2. To add nested styles to a single paragraph,
choose Drop Caps And Nested Styles from
the Paragraph panel menu.
Note: For best results, apply nested
styles as part of paragraph styles. If you
apply nested styles as local overrides to
a paragraph, subsequent editing or formatting changes in the nested style can
produce unexpected character formatting in the styled text.
3. Click New Nested Style one or more times.
4. Do any of the following for each style, and
then click OK:
•

•
•
•
•

Click the character style area, and then
select a character style to determine the appearance of that section of the paragraph.
If you haven’t created a character style,
choose New Character Style and specify
the formatting you want to use.
Specify the item that ends the character style formatting. You can also type the character, such as a colon (:)
or a specific letter or number. You cannot type a word.
Specify how many instances of the selected item (such as characters, words, or sentences) are required.
Choose Through or Up To. Choosing Through includes the character that ends the nested style, while choosing Up To formats only those characters that precede this character.
Select a style and click the up button or down button to change the order of the styles in the list. The order
of the styles determines the sequence in which the formatting is applied. The formatting defined by the second style begins where the formatting of the first style concludes. If you apply a character style to the drop
cap, the drop-cap character style acts as the first nested style.

This videos tells it all http://layersmagazine.com/working-with-nested-styles-in-indesign.html
http://tv.adobe.com/watch/learn-indesign-cc/creating-nested-styles-2/
http://help.adobe.com/en_US/indesign/cs/using/WSE33E49F9-94CE-4043-AA51-4761408A63F4a.html
•
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CREATING GREP STYLES
A GREP expression is an advanced method for locating text and special characters in a document. GREP (Global
Regular Expression Print) is used by the Find/Change dialog box to find and replace text and special characters,
such as tabs, ends of paragraphs, white space, variables, and wildcards. You can create a style to apply a character style to text that conforms to a GREP expression. A GREP style is a Character style with a GREP expression.
When text matches the GREP expression, the character style is applied to the text. In the GREP Styles
and Find/Change dialog boxes (where you can
select a character or paragraph style), you can create
a style without having to exit the dialog box.
1 Select the Paragraph Styles panel.
Click the Type menu, and then click Paragraph Styles.
2 Click the Options menu, and then click New
Paragraph Style.
To add a GREP expression to an existing
style, select the style,
click the Options menu, and then click Style
Options.
3 Enter a name for the style.
4 Select each category to set text attributes.
5 Select the GREP Style category.
6 Click New GREP Style.
7 Click to the right of Apply Style, and then select a
character style or click New Character Style to create one.
8 Click to the right of To Text, and then enter a
search expression or click the Special Character For
Search icon to the right to display a menu. Choose
options from the Locations, Repeat, Match, Modifiers, and Posix submenus to help construct the
GREP expression.
9 Click OK.

GREP STYLE PAGE 414
video: http://layersmagazine.com/using-grep-styles-in-indesign.html
http://vector.tutsplus.com/tutorials/designing/quick-tip-automatic-formatting-using-grep-styles-in-adobe-indesign/
expressions: http://www.gskinner.com/RegExr/
http://vector.tutsplus.com/tutorials/designing/quick-tip-automatic-formatting-using-grep-styles-in-adobe-indesign/
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WHERE TO FIND WHAT WE WORKING ON IN THE BOOK

Tools

page 18

Choosing Panels

page 2

Setting up a document

page 23

Application bar

page 48

Using control panel for text

page 85

Using control panel for object

page 117

Tab

page 325

Paragraph styles -

page 392

Character styles

page 396

Object styles

page 415

Master pages

page 277

page numbering

page 302

Tabs

page 328

Story editor

page 376

Tracking

page 376

text wrap

page 121 / options 241
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Find / change

page 364

Glyphs

page 5, 77, 79

Opentype Categories

page 437

Effects

page 170

Export pdfs -

page 491

Adobe website text(but it is cs6 now): http://www.adobe.
com/products/indesign.html
Adobe website video: http://tv.adobe.com/show/learnindesig n-cs5/

In Tabs

IN THE BOOK- PAGE 325

SET TABS

Tabs position text at specific horizontal locations in a
frame. The default tab settings depend on the Horizontal ruler units setting in the Units & Increments preferences dialog box.

You can set left, center, right, and decimal or specialcharacter tabs. When you use the special-character tab,
you can set a tab to align to any character you choose,
such as a colon or a dollar sign.

Tabs apply to an entire paragraph. The first tab you set
deletes all default tab stops to its left. Subsequent tabs
delete all default tabs between the tabs you set. You can
set left, center, right, and decimal or special-character
tabs.

Bob Bringhurst provides an article about various
tab and indent effects at Tabs and Indents
Gallery. - “http://blogs.adobe.com/indesigndocs/2009/09/tabs_and_indents_gallery.html”
is on my website with link

You set tabs using the Tabs dialog box.

1.

Using the Type tool , click an insertion point in
the paragraph.

2. Press the Tab key. Add tabs in the paragraphs
where you want to add horizontal space. (You
can also add tabs after you create your tab settings.)
3. Choose Type > Tabs to display the Tabs dialog
box.
Tabs dialog box
A. Tab alignment buttonsB. Tab positionC. Tab Leader boxD. Align
On boxE. Tab rulerF. Snap above frame

OPEN THE TABS DIALOG BOX
1.

Using the Type tool, click in the text frame.

2. Choose Type > Tabs.
3. If the top of the frame is visible, the Tabs dialog
box snaps to the current text frame and matches its width to the current column.

4. To specify which paragraphs will be affected,
select a paragraph or a group of paragraphs.
5. For the first tab, click a tab-alignment button
(left, right, center, or decimal) in the Tabs dialog
box to specify how text will align to the tab’s
position.
6. Do one of the following:
Click a location on the tab ruler to position a
new tab.

4. Align the Tabs dialog box ruler with your text
5. Scroll through your document to display the top
of the text frame.
6. Click the magnet icon  on the Tabs dialog box.
The Tabs dialog box snaps to the top of the column that includes the selection or the insertion
point.
7. To the top

Adding a new tab setting

Type a position in the X box and press Enter
or Return. If the X value is selected, press
the up or down arrow key to increase or decrease the tab value by 1 point, respectively.
For subsequent tabs with different alignments, repeat steps 3 and 4.

This is from: http://help.adobe.com/en_US/indesign/cs/using/WSa285fff53dea4f8617383751001ea8cb3f-6dbba.html
youtube - https://www.youtube.com/watch?v=QG1Sx-vHMRA
7
http://indesignsecrets.com/tab-tab-tab.php

FIND/CHANGE IN THE BOOK- PAGE 325
This does more than just find text and change it. The
Find/Change dialog box contains tabs that let you specify
what you want to find and change.
Find/Change dialog box
A Find/Change tabsB. Find a tab characterC. Replace with an em
dashD. Search optionsE. Metacharacters menu

Text Search for and change specific occurrences
of characters, words, groups of words, or text
formatted a certain way. You can also search for
and replace special characters such as symbols,
markers, and white space characters. Wildcard
options help to broaden your search.
GREP Use advanced, pattern-based search techniques to search for and replace text and formatting.
Glyph Search for and replace glyphs using Unicode or GID/CID values, especially useful to search for and
replace glyphs in Asian languages.
Object Search for and replace formatting effects and attributes in objects and frames. For example, you
can find objects with a 4-pt stroke and replace the stroke with a drop shadow.
Full explanation see book, or go to:
http://help.adobe.com/en_US/indesign/cs/using/WSFB3603CC-8D84-48d8-9F77-F3E0644CB0B6a.html
youtube: http://www.youtube.com/watch?v=Bes7VWnSvXI

GREP PAGE 368
http://www.kahrel.plus.com/indesign/grep_query_manager.html
cheat sheet: http://www.addedbytes.com/cheat-sheets/regular-expressions-cheat-sheet/
REP in a style sheet: http://indesignsecrets.com/5-cool-things-you-can-do-with-grep-styles.php

GREP STYLE PAGE 414
video: http://layersmagazine.com/using-grep-styles-in-indesign.html
http://vector.tutsplus.com/tutorials/designing/quick-tip-automatic-formatting-using-grep-styles-in-adobe-indesign/
expressions: http://www.gskinner.com/RegExr/
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CREATING FORMS
Simple forms using tabs (page 324)
Name (tab)
Address (tab)
(tab)
email (tab)
phone (tab)

With rules above.
NAME 6/20, RULE ABOVE
ADDRESS

EMAIL
PHONE

Forms using tables (page 329)

TABLES
http://www.wikihow.com/Add-Table-in-InDesign
http://www.macprovideo.com/hub/indesign/creating-stylish-tables-in-indesign
http://indesignsecrets.com/category/secrets/tables
http://help.adobe.com/en_US/indesign/cs/using/WSa285fff53dea4f8617383751001ea8cb3f-6fd9a.html
first row
second row
third row
fourth row
this is good

this is
this is better amazing

this is beyond
all of it

what do you where do you
yet another
think
go
what day is it thought
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GRAPHICS

Nesting Graphics (PAGE 222)
Ihis is why you would wnat an image box,
within an image box:
1st place an image - in say a round container:
Then paste this in the second container, and
size and move to where it is how you would
like it
http://designertoday.com/Tutorials/InDesign/4731/The.Art.of.Nesting.InDesign.Tutorial.aspx

Nesting (Ancoring) Graphics in text (PAGE 251)
You have two choices for anchoring objects: You can anchor existing objects or you can anchor placeholder
objects. To anchor an existing object in text:
Select any object or group using one of the selection tools.
1. Choose Edit > Cut or Edit > Copy.
Ciumendem et rectia quaturi busdaepudit omnistiunt rectur?
2. Select the Type tool and click in text to position the inserDaesequos qui unt quodis int.
tion point where you want the anchored object.
Et eat. Upidem ea nobit et perchitatet
3. Choose Edit > Paste.
lissimus.
Nequidellit quaerehenem exera vo4. By default, the object is anchored Inline, but you can
reposition it using the Anchored Object Options dialog luptatiunt volorrovit ipsum iur millictiam alicab
box. If the object is larger than surrounding text, it may in exeratiistia dolendunt molupti ossitatem dem
overlap the text; in that case, you may need to adjust the ad ea vollaudi optaerum harumenet utet aruptas
peliquatur am alit et res seriorerum aut acero tori
leading or insert line breaks.
debis utem auda dolor rem vit lab in non pe pa
Anchoring Placeholder Objects
qui cuptist iosandel ideliciisque pedit, alignimusa
If you haven’t created the object that will be anchored—or if prestotam eniet laccatibusa estrume nonsed et
its content is not ready—you can create a rectangular place- harum rerum endiore num qui solorestia nullupholder and anchor it in text. To do this:
tatio endam landell uptatum esciis poruptatur a
nosam, ipsam ulparum que cus assitia dolut hili1. Select the Type tool and click in text to position the text
quas debis doluptistia dolorepedi blanis ellessimi,
insertion point.
voluptatiis quis autat laturiorum nis quia doloria
2. Choose Object > Anchored Object > Insert.
3. In the Object Options area at the top of the Insert Anchored Object dialog box, specify the Content for the
object (such as Text or Graphic).
4. Select an Object Style to specify the object’s formatting (if you’ve created any object styles).
5. Select a Paragraph Style for the text it will contain (if the object is a text frame).
6. Enter a Height and Width for the object.
7. You can also specify the position of the anchored object, as discussed in the next section.
http://designertoday.com/Tutorials/InDesign/4731/The.Art.of.Nesting.InDesign.Tutorial.aspx
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HOW TO LAYOUT A BOOK IN INDESIGN
by David Weedmark, Demand Media

http://smallbusiness.chron.com/layout-book-indesign-27014.html

You can use Adobe InDesign to create a professional-looking e-book or a book for print publication. First determine how you want the pages set up for the entire book, then create the layout for the master pages, which act as
templates for all the pages of the book so the layout for each type of page is consistent. You can then focus on the
layout of each page and add the content.
Creating a Document
1 Launch Adobe InDesign. Click
the “File” menu, select “New,”
then “Document” to open the
New Document window.
2 Click the “Intent” menu and
select “Print” for a print book
or “Web” for an e-book. A print
book should have “Facing Pages”
checked, and an e-book should
not.
2 Check the “Master Text Frame”
option if you plan to use page
numbers, footers or headers on
each page.
4 Click the “Page Size” menu, or use
the Height and Width fields to set
the page size. Specify your margins for each page in the Margins
section.
5 Enter a value in the “Number of
Pages,” if desired. You can add and
remove pages later using the Pages
panel.
6 Click “OK” to create the document. Note that each page has a
black line showing the page size
and a blue line showing the margins.

Setting Up the Master Pages
Adding Text
1 Click on a ”Master” page icon in 1 Click the first page in the Page
the Pages panel to make changes
panel to make it appear in the
to one master page. The master
main window. Select the text tool.
page appears in the main window
2 Click the “New Page” icon to add
and acts as a template for the
a new page, or drag a master page
pages of your book. Changes you
into the Pages panel. Drag a masmake to the master affect all pages
ter page onto any page to change
using that master.
it. To create a blank page, drag the
2 Click the “Type Tool” in the
“None” master onto the page.
Toolbox and drag it across the
3 Click the first page of the book
master page to create a text box
in the Pages panel. Drag the Text
that is within the margins, to create a header or footer to appear on tool across the page where you
want the text to appear within the
every page using this master.
margins.
3 Insert a page number on each
page by dragging the text tool in 4 Type or paste the text of your
book into the text box. If there is
the bottom corner of the master
too much text to fit on the page,
page. Click the “Type” menu,
use the Selection tool to click the
select “Insert Special Character,”
“+” sign that appears on the botthen “Auto Page Number.”
tom right corner of the text box,
4 Repeat this process for the second
then click the text box in the next
master page if you are using facpage. The text flows into the next
ing pages. Remember to put the
page.
page number on the opposite side
of a facing page.
5 Add additional master pages as
needed to create a different layout
for first pages of chapters, or pages
without page numbers. Click the
“New Master” in the Pages panel
menu.

quickstart on line:
http://my.safaribooksonline.com/book/graphic-design/9780133006070/10dot-pages-and-books/ch10sec1lev12
http://www.youtube.com/watch?v=GY16m7QcFj4
http://www.computerarts.co.uk/tutorials/design-and-lay-out-book-indesign?page=1
http://www.computorcompanion.com/LPMArticle.asp?ID=304
http://profesorazii.blogspot.com/2009/06/q-how-to-make-book-in-indesign-ans-with.html
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HARD TO REMEMBER
TEXT VARIABLES
1. If you want to create text variables for use in all new documents you
create, close all documents. Otherwise, the text variables you create appear only in the current document.
2. Choose Type > Text Variables > Define.
3. Click New, or select an existing variable and click Edit.
4. Type a name for the variable, such as “Full Chapter” or “Running Title.”
5. From the Type menu, choose a variable type, specify the options for
that type, and then click OK.
Different options are available depending on the variable type you select.
http://vector.tutsplus.com/tutorials/designing/quick-tip-how-to-make-running-headersin-adobe-indesign/

MARKERS
Current page
Be in a text box, and click Current page
Next Page/Previous Page
Same as above..BUT the text with the next page/previous page, must over lap
the text box on that page
http://www.aaronzalonis.com/page-numbering-and-section-markers-in-indesign/
http://indesignsecrets.com/free-guide-to-indesign-special-characters.php-really useful
video
http://dbdaishu.com/design/index.php/page-layout/141-indesign-cs6-page-numberssection-markers-and-table-of-contents
http://help.adobe.com/en_US/indesign/cs/using/WSa285fff53dea4f8617383751001ea8cb3f-7111a.html#WSa285fff53dea4f8617383751001ea8cb3f-710ca
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SPECIAL CHARACTERS
Tab
instead of using the tab key you can
use this (this will automatically be a
left tab)

end Nested Styles
if using nested styles (will talk about
htis) can end it where you mark or in
a style sheet

Tab indent right
Is a tab that goes to the end of the
box.VERY USEFUL when you might
change the size of the box, the tab
will still go the where ever the end of
the box is.

Non Joiner
If you don’t what a a glyph of two letters you want them as seperate letters
like: ſl would just fl

Indent to Here
If you suing quotes or a character and
then texgt, and you want all the text
indented after the quote

TOC
Create a TOC style
1. Choose Layout > Table Of Contents Styles.
2. Click New.
3. Type a name for the TOC style you are creating.
4. In the Title box, type a title for your TOC (such as
Contents or List of Figures). This title will appear
at the top of the table of contents. To specify a title
style, choose a style from the Style menu.
5. From the Other Styles list, select the paragraph
styles that represent content you want to include in
the table of contents, then click Add to add them to
the Include Paragraph Styles list.
6. Specify options to determine how each paragraph
style is formatted. (See Options for formatting a
table of contents.)

7. Import TOC styles from another document
8. Choose Layout > Table Of Contents Styles.
9. Click Load, select the InDesign file containing the
TOC styles you want to copy, and then click Open.
10. Click OK.Next Page/Previous Page

Same as above..BUT the text with the next page/previous page, must over lap the text box on that page
http://www.macprovideo.com/hub/indesign/creating-a-stylish-table-of-contents-in-indesign
video:	
http://layersmagazine.com/easy-table-of-contents-creation-in-adobe-indesign.html
http://dbdaishu.com/design/index.php/page-layout/141-indesign-cs6-page-numbers-section-markers-and-table-ofcontents
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